UUID sminkiato ? No problem!

Ultimante sul mio piccino durante la fase di boot (nella splash-screen) mi comparivano due avvisi che recitavano questo:

swap waiting for uuid: XXXXXXXX (vari numeri e lettere)

Ora il sistema si è sempre avvito senza problemi e quindi non ho dato molto peso al problema, ma ogni volta che avviavo Elena (aka Mint8) sul mio piccino avevo questo avviso e qualche rallentamento nelle prestazioni (e certo non mi montava le partizioni di swap!).(ecco si è lei la mia Elena mentre consulta i registri UUID :D)

Quindi dopo qualche settimana ho deciso di indagare e come spesso accade lo zio guuugle mi ha donato la soluzione, o meglio mi ha fatto cercare sul Forum di Ubuntu-it che puntualmente mi indirizza al post adatto a me 😀

Allora il problema del post riguardava l’upgrade da ubby 9.04 (la mitica jaunty) ad ubby 9.10 (il koala) tuttavia ho ipotizzato che la soluzione per me fosse la stessa (visto che erano gli stessi avvisi) che sinteticamente è questa:

Visualizzare il numero UUID corretto: sudo blkid

Dando questo comando (dopo aver inserito la vostra password) vi compariranno tutti gli UUID associati alle vostre partizioni (quelli corretti), in pratica ogni vostro disco e ogni vostra partizione ha un suo numero di identificazioni ben preciso (che corrisponde a sua volta ad un suo numero in codice binario) che viene chiamato UUID.

Verificare se l’UUID che l’OS ha in memoria è corretto: sudo gedit /etc/fstab

Una volta fatto questo lasciate aperto il terminale (cosi avrete sempre in vista i vostri UUID corretti) e date il comando che vi aprirà un foglio dove sono registrati tutti i dischi e le partizioni con i relativi UUID registrati al momento dell’installazione del sistema (l’UUID non so perché può variare, ad esempio dopo una nuova installazione di un OS accanto ad un altro [come nel mio caso]).

Se gli UUID che vi danno problemi non coincidono tra di loro ( e quindi non sono corretti) allora modificare le stringhe di codice UUID incollando le stringhe ottenute col primo comando (sudo blkid), ovviamente stando attenti a modificare le stringhe che ci interessano, ad esempio a me non montava le due partizioni di swap quindi ho guardato quali erano le mie due partizioni di swap (sda5 ed sda7) e le ho corrette.

Una volta fatto salvare il foglio e riavviare, et voilà avremmo magicamente risolto il problema 😀

#: dev/null/

PS: Non sarò mai abbastanza grato al forum di Ubuntu-it per le trentordici volte che mi sono stati utili è davvero una folta e completa comunità 😀

PS#2: ovviamente se non usate Gnome sostituite gedit con il vostro editor di test predefinito oppure semplicemente installate gedit 🙂

Quando il pennuto non collabora…..

Salve ragazzi bentornati, come molti di voi sanno è da poco uscito Thunderbird 3.1, e io che sono un grande utilizzatore di email sono corso subito ad aggiornarlo con ubuntuzilla (enorme errore!).

Quindi tutto contento ho dato sul terminale: ubuntuzilla.py -p thunderbird
Il tutto si è aggiornato in pochi minuti e tutto contento avvio il rapace……aspetto….aspetto….aspetto….e ovviamente bestemmio contro quel dannato uccello!
“Ok stiamo calmi” mi dico, “avviamolo da terminale”:
picchio@picchio-netbook~ $ : thunderbird

picchio@picchio-netbook~ $ : (thunderbird-bin:2400): GLib-WARNING **: g_set_prgname() called multiple times
Mmmmm…perfetto…ottimo….in pratica non ci ho capito un ca$$o di questo log e sono corso a cercarlo dallo zio google in cerca di soluzione, ma nulla, cosi ho deciso di limitare la ricerca solo all’interno del forum di Ubuntu-it.
E li trovo un post con su diverse persone con diversi errori con diverse soluzioni, io ne ho provate due ma nulla, cosi ho improvvisato e ringraziando tutti gli Dei dell’olimpo del pinguino sono riuscito a far ragionare il pennuto!
Quindi la soluzione da me trovata è questa:
1) Rimuovo thunderbird 3.1 non funzionante con:
ubuntuzilla.py -a remove -p thunderbird
2) Installo thunderbird 2 da repo di Ubuntu (sudo apt-get install thunderbird), sono sul piccino quindi su Karmic (Mint8) e nei repo trovo TB2;
3) Aggiorno thunderbid 2 alla 3.1 normalmente da ubuntuzilla:
ubuntuzilla.py -p thunderbird
Ora funge tutto ma ho perso tutte le mie mail che però posso recuperare visto che uso gmail con IMAP.
Quindi alla fine vissero tutti felici e rapaci 😀
We Love Picchio && Thunderbird
PS: Notate che molti programmi per GNU/Linux adottino nomi di uccelli ?! E notate come manchi proprio il “picchio” come nome da utilizzare per un programma ?!

PS#2: Ovviamente per adesso sconsiglio a tutti voi di fare l’update a thunderbird 3.1 visto che dovreste fare un downgrade e poi un upgrade per ottenere l’ultima relese del rapace e vi assicuro che non ci sono grandi differenze che incitano all’immediato update, a parte il wizard che ci guida nella transizione da TB2 a TB3.1 😀

PS#3: Naturalmente ringrazio tutti i ragazzi del forum Ubuntu-it perché senza di loro non avrei mai capito come rimuovere TB da ubuntuzilla 😀 (mi riferisco al comando: ubuntuzilla.py -a remove -p thunderbird).

Impossibile cazzeggiare: Pacchetti danneggiati!

Ok ero li tutto contento in attesa degli update per docky e altre cose sbav….no aspettate mi devo limitare, allora ero li in attesa che il gestore degli update mi installasse appunto gli updates e………………..be si mi parte abbondantemente la bestemmia:
Cosi cerca di qua e cerca di la, trovo varie discussioni su problemi simili sul forum di Ubunti-it, che riassumendo suggerivano tali comandi:

sudo apt-get install -f

sudo apt-get autoclean

sudo apt-get clean

sudo apt-get autoremove

Ma non poteva mica essere cosi semplice, no no!(mia reazione ai tentativi falliti)

Ovviamente anche facendo pulizia il tutto restava smerdato, cosi mi sono rivolto a Lippol che per volere divino/alieno ha perso la sua connessione a tempo indeterminato, quindi dopo alcuni minuti di riflessione su Futurama grazie al professore sono quasi arrivato alla soluzione:

Infatti mi son detto ma perché non fare come in ambito rolling relese, mi spiego meglio, perché non provare a comandare da terminale gli updates cosi come faccio su Sidux.

Cosi ho dato un bel: sudo apt-get upgrade

e gli aggiornamenti partono!

Ma ovviamente per il volere divino/alieno non tutti gli updates vengono effettuati, infatti gli updates di docky e del kernel non vengono eseguiti dal precedente comando.

Cosi mi rivolgo al mio semiDio preferito: Lightuono(lightuono ogni volta che entra su pidgin)

Che mi ha subito illuminato la via e mia ha condotto alla redenz….no, mi ha condotto alla soluzione para-divina:

sudo apt-get dist-upgrade

Cosi come per magia aiutato dai super poteri di super mucca…
….sono riuscito ad aggiornare e a risolvere il problema degli invisibili pacchetti danneggiati, si si invisibili, perché aprendo Synaptic non trovava nemmeno l’ombra di un pacchetto danneggiato (bha misteri di APT).

Tutto e bene quel che finisce bene 😀

>>> Dev Null 😛

PS: Giuro ho riletto tre volte il post e non ho visto errori, ma essendo umano posso sempre sbagliare quindi vi prego se ne trovate segnalateli nei commenti grazie 😀

PS#2: Prima del verificarsi dell’errore ho installato questo programma aggiungendo i ppa suggeriti, forse i problemi sono originati dal quel ppa.