Leggere è importante

Leggere è importantissimo, soprattutto quando state aggiornando la vostra distribuzione (nel mio caso Arch Linux) e pacman vi avverte che c’è un problema simile:

attenzione: è stato individuato un ciclo di dipendenza:
attenzione: systemd sarà installato prima della sua dipendenza dbus-core

Non so da cosa dipenda tale problema comunque dopo una rapida ricerca sul forum di arch ho capito come risolverlo, ovvero basta fermare l’update e aggiornare singolarmente dbus-core,

sudo pacman -S dbus-core

Dopo che si sarà aggiornato ridiamo un pacman -Syu e il problema sarà risolto😀

:# /dev/null/

Fonte: Forum di Arch Linux

12 thoughts on “Leggere è importante

  1. Beh ma perchè? che problema c’è se pacman incontra un ciclo di dipendenze e avvisa che nell’eseguire l’upgrade un pacchetto avrà precedenza su un altro?

    • In teoria non ci dovrebbe essere il problema ma dal numero di utenti che postano sul forum è possibile vedere come in certi casi questo possa fottere il sistema, quindi è sempre meglio assecondare pacman in questi casi e installare/aggiornare prima quello che dice lui risolvendo il ciclo.

      • Solo a titolo informativo: ho provato ad aggiornare normalmente senza fare nulla nonostante la comparsa del messaggio e non ho avuto problemi. Siamo sicuri che gli errori riportati in internet siano causati da quel ciclo di dipendenze e non da altro?

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...